ICAB3018B: Develop macros and templates for clients using standard products

Student Handbook
### Modification History – Competency Handbooks

<table>
<thead>
<tr>
<th>Version</th>
<th>Date of Release</th>
<th>Authorisation</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>16/06/10</td>
<td>S.Morris</td>
<td>Primary Release</td>
</tr>
</tbody>
</table>

**Forms Control:**

All documents related to the delivery or assessment of ICA20105: Cert II in Information Technology will have a version number displayed in the footer of the document. This Modification History page will appear after each title page of a handbook to ensure that the materials involved in the delivery and assessment of the certificate remain in a constant state of ongoing review and improvement. Comments on changes will only show sufficient detail to enable a user to identify the nature and location of the change. Documents will be reviewed at least on an annual basis at the official internal review and fellow instructors and industry representatives will be consulted throughout the year in informal discussion.
UNIT CODE: ICAB3018B

UNIT TITLE: Develop macros and templates for clients using standard products

Description

This unit defines the competency required

Elements of Competency

<table>
<thead>
<tr>
<th>ICAB3108B/01 Determine macro or template requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1 Determine client requirements, ensuring they are in line with organisational guidelines</td>
</tr>
<tr>
<td>1.2 Develop macro or template specification</td>
</tr>
<tr>
<td>1.3 Confirm that macro or template specification meets the clients needs and operational guidelines</td>
</tr>
<tr>
<td>1.4 Determine documents requirements.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ICAB3108B/02 Develop macro or template for client</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1 Develop macro or template to specification using industry-recognised software applications</td>
</tr>
<tr>
<td>2.2 Demonstrate macro or template to client and obtain feedback</td>
</tr>
<tr>
<td>2.3 Amend Macro or template, as required by client.</td>
</tr>
<tr>
<td>2.4 Update macro or template specification.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ICAB3108B/03 Provide client support for macro or template</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1 Document support and instruction requirements.</td>
</tr>
<tr>
<td>3.2 Provide documentation to client help desk for future support</td>
</tr>
</tbody>
</table>
Creating Macros in Word

For many Word users, the term macro strikes fear in their heart, mainly because they do not fully understand Word macros and have most likely never created their own. Fortunately, creating and running macros isn't too difficult, and the resulting efficiency is well worth the time spent learning to use them. Keep reading to learn how to work with Macros in Word 2003.

Simply put, a macro is a series of commands that is recorded so it can be played back, or executed, later. There are a couple different ways to create Word macros: The first, and easiest way, is to use the macro recorder; the second way is to use VBA, or Visual Basic for Applications. Further, Word macros can be edited by using the VBE, or Visual Basic Editor.

There are over 950 commands in Word, most of which are on menus and toolbars and have shortcut keys assigned to them. Some of these commands, however, are not assigned to menus or toolbars by default. Before you create your own Word macro, you should check to see if it already exists and can be assigned to a toolbar.

To see the commands available in Word, press “alt+f8” In the drop down box beside the Macros in: label, select Word Commands.

1. On the Tools menu, select Macro and then Macros…from the submenu; you can also use the Alt + F8 shortcut key to access the Macros dialog box

2. In the drop down box beside the Macros in: label, select Word Commands

3. An alphabetical list of the command names will appear. If you highlight a name, a description of the command will appear at the bottom of the box, under the Description label
If the command you wish to create already exists, you should not create your own Word macro for it. If it doesn't exist, you should proceed to part two: planning your Word macro.

**Recording macros**

If you’ve planned your macro carefully enough, recording it for later use will be the easiest part of the process. It is so easy, in fact, that the only difference between creating a macro and working on the document is that you have to press a few extra buttons and make a couple of selections in dialog boxes.

The first step is to open the Record Macro dialog box by selecting Record New Macro… from the Tools menu:

The Record Macro dialog box appears:

In the box beneath the Macro name: box, type a unique name. Names can contain up to 80 letters or numbers (no symbols or spaces) and must begin with a letter. It is advisable to enter a description of the actions the macro performs in the Description dialog box, but the name you assign the macro should be unique enough that you remember what it does without having to refer to the description.

Once you have named your macro and entered a description, you should select whether you want the macro to be available in all documents or only in the current document. By default, Word makes the macro available to all your documents, and you will probably find that this makes the
most sense. Should you choose to limit the availability of the command, however, simply highlight the document name in the drop down box below the Store Macro in: label.

When you have entered the information for the macro, click OK. The Record Macro Toolbar will appear in the upper left corner of the screen:

The mouse pointer will now have a small icon that looks like a cassette tape beside it, indicating that Word is recording your actions. You can now follow the steps you laid out in the planning stage; once you are done, press the Stop button (it is the blue square on the left). If, for any reason, you need to pause the recording, simply press the Pause Recording/Resume Recorder button (it is the one on the right). To resume recording, press it again.

Once you press the Stop button, your Word macro is ready to use. To run it, use the Alt + F8 shortcut key to bring up the Macros dialog box; highlight your macro in the list and then click Run. If you don’t see your macro, make sure the correct location is in the box beside the Macros in: label.

**Activity 1**

One of the drawbacks of having so many commands and options available is that it can be difficult learning what and where they all are. Fortunately, Microsoft has included a macro in Word 2003 that will display a list of all the commands, their locations, and their shortcut keys. If you want to know everything there is to know about Word, start here:

1. From the Tools menu, select Macro
2. On the submenu, click Macros
3. In the Macro in drop-down, select Word commands
4. In the Macro name box, scroll to find ListCommands and select it
5. Click the Run button
6. When the List Commands box appears, select Current menu and keyboard settings for an abbreviated list or All word commands for an exhaustive list
7. Click the OK button
8. Save this document as Activity 1 in your drive in a folder labelled ICAB3018B.

**Activity 2**

1. You will need to access the file activity 2 on the shared drive and create a shortcut key macro which will change the case of all the words to “Title Case”.

2. You will then have to create a macro which will change the font to the colour red. Now demonstrate your macros to your teacher and save the document in your drive as Activity 2.
Activity 3

You need to create three following signature macros for our school leaders (Principal and both Deputy Principals). You should do this in a document, then demonstrate each one to your teacher for marking. The macros should follow the format below:

Yours sincerely

8 returns for a signature space

Mr Ross Higgins
Principal
Aldridge State High School

Activity 4

1. You are to access the web page
   Save the web page. If you do not know how to do this Google it respective to your internet browser. Save the file with the extensions ".mht"

2. You are then to open this file in word and then create a macro to replace all the words "monopoly" with the word "DupBlock".

Templates

If you frequently create documents that contain a lot of specialized formatting but don't always contain the same text, you can save yourself a considerable amount of time if you create Word templates to use as the basis of future documents. By using Word’s template feature, you can focus your concentration on the content of the document and leave the formatting up to the template.

For those who are unfamiliar with templates, a template is, simply put, a style guide for documents. A Word template can contain formatting, styles, boilerplate text, headers, footers, and macros, in addition to dictionaries, toolbars, and AutoText entries.

Before you create your Word template, it is a good idea to outline what you want to include in it. You can always go back and edit your template or make changes to elements in documents created from the template, but the little time you spend planning will save you more time in the long run. Here are some tips on what to include:
If you're creating a Word template to use as a letter, insert a date field that will update automatically each time the template is opened.

Again, if the template will be used to create letters, include your address and contact information.

Headers and footers. Use fields or Auto text for information that may change but will always contain the same type of information (i.e., page numbers, document title, file path, etc.).

Any text that will be included in all documents based on the template.

Columns, margins, tab stops, endnotes, footnotes, etc.

Macros. If you want to use specific macros with the document, include them with the template.

If your document contains different regions with different formatting, but these regions will not be distinguishable on a blank page, use a descriptive name as placeholder text (i.e. Title, heading, body, or the like). When you open a new document based on the template, you can simply highlight the placeholder text and type over it; text entered in its place will contain the same formatting.

Once you have outline of what you want to include in the Word template and have created a blank document containing all the elements in the outline, you are ready to go on the next step, saving the document as a Word template.

**Fill-in fields**

To create a template with automatic fill-in fields, follow these steps:

1. On the File menu, click New.
2. In the New Document task pane, in the Templates section, click On my computer.
3. In the Create New box select Template.
4. Click Blank Document, and then Click OK.
5. Create the fill-in fields. To do this, use either of the following methods.
   a. Method 1: Create a field by using the menus.
      i. Position the insertion point where you want to insert the text field.
      ii. On the Insert menu, click Field.
      iii. In the Categories list, click Mail Merge.
      iv. In the Field Names list, click Fill-in.
      v. In the Field properties Prompt box, type the message that you want to appear.
      vi. Click OK. A sample of the message appears. Click OK to return to your document.
   b. Method 2: Create a field by using keystrokes.
      i. Position the insertion point where you want to insert the field.
      b. Position the insertion point inside the field braces.

   Note To view the field code that you inserted, right-click the field, and then click Toggle field codes. Alternatively, press ALT+F9 on the keyboard.
   g. Repeat steps a through f for every location in the document where you want to insert a fill-in field.
c. Type:

FILLIN "message"

where message is the instruction that Word prompts the user with.

Note If you press F9 while the insertion point is still on the field, you can see a sample of the message. You do not have to follow this step to create the fill-in field.

6. On the File menu, click Save As.
7. Name the template.

Activity 5

You have been asked to design a memorandum template for Aldridge State High School. You will need to do the following steps.

1. Compose a rough design of what your template is going to look like. You may do this in any image creating program.

   Save as Activity 5.1

2. You will need to create the memorandum using the following template rules.
   - Size 36 comic sans font for headings
   - Size 8 underlined Arial black for the details
   - Size 22 bold times new roman for the body
   - Add the school logo to the top of the document

   Save as Activity 5.2

3. The client is happy with the result but would like you to refine some things for them.
   - Size 30 times new roman for the heading
   - Size 10 times new roman for the details
   - A separating line between the body and the details
   - Size 10 times new roman for the body
   - A size 12 bold times new roman title for the body

   Save as Activity 5.3

Activity 6

You need to access the file “failure to submit assignment”
And add fill in fields to these phrases.

- Due date.
- Student name
- Parent Name
- Street Address
- MARYBOROUGH QLD 4650
ICAB3018B: Develop macros and templates for clients using standard products

- Today’s Date
- Teacher name
- Teacher Position - Subject Name

Save it as a Template called Activity 6

**Activity 7**

The client Aldridge state high school would like you to develop a template for their newsletter. It must include:
- A logo
- A header / footer
- A title page
- Relevant contact information
- Titles
  - From the principal
  - Payment policy
  - Community notices
- A blank final page

The client would also like you to add the following text formats:
- Size 30 times new roman for the heading
- Size 10 times new roman for the details
- Size 10 times new roman for the body
- A size 12 bold times new roman title for the body

Save the Template as Activity 7

**Activity 8**

You have been asked to design a profit/loss template in excel for Aldridge State High School. You will need to do the following steps.

1. Compose a rough design of what your template is going to look like. You may do this in any image creating program.
   
   Save as Activity 8.1

2. You will the need to create the spreadsheet using the following template rules.
   - Size 10 font for body
   - Size 15 font for headings

   Save as Activity 8.2

3. The client is happy with the result but would like you to refine some things for them.
   - Size 10 font for body
   - Size 15 font for headings
   - add sum formulas for totals of all fields

   Save as Activity 8.3